Teams Call Quality Dashboard data missing or delayed for some users in West European regions

Incident Report for Martello

Update

We are continuing to monitor for any further issues.
Posted Mar 21, 2025 - 19:56 UTC

Monitoring

After a thorough investigation, we have determined that missing or delayed call logs is isolated to Microsoft CQD services for some customers in Western European regions and there is no issue with the
Vantage DX infrastructure. Our team is actively monitoring the situation and we kindly ask that you open a CQD support request with Microsoft.

Please contact Martello Technical Support if you require help or guidance when raising a support request with Microsoft.
Posted Mar 21, 2025 - 17:43 UTC

Investigating

We are seeing indications that the problem may be due to a Microsoft issue and not Vantage DX.

We will continue to update as information becomes available.

Please do not hesitate to contact the Support team if needed Technical Support
Posted Mar 12, 2025 - 13:19 UTC
This incident affects: Vantage DX.